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ECDL Module 4 — Spreadsheets (Excel)
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Study resources for the module.

Modules 2-7 of the ECDL examination are practical examinations, in other words,
the student is expected to show competent knowledge in the use of the
applications. This knowledge may only be gained through continual practice,
gained through using the application and experimenting with various scenarios.

It is very important that the student does not solely rely on the work that is done
in the classroom, but supplements their knowledge by searching the internet for
past papers and attempting them, asking where they do not understand. These
notes are designed to supplement course content delivered in class and should
not replace any notes you should be taking. Remember people have failed the
exams because they could not interpret the question and did not know what the
examiner was asking them to do.

Online sources

http://www.stmichaelfoundation.org > syllabus > Computer Studies and ICT> ECDL

http://www.ghalliem.net

Google seach engine > type in +ECDL +Module +4 +Practice +Papers (or any other similar

combination)

General Setup Guide
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Title Bar

Name Box
\ Cut Paste
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Paste Format Painter Chart Wizard Zoom Indent
\ v
B~ < Borders
= = = L
/ / A Decimals
Aliament L/C/R Merae Cells Currency Percentage |
Thousand Separator
Worksheets

Formulae

NN

1% Sheetl / Sheet2 / Sheet3 /

Formulae ALWAYS start with the = sign, then the function and an (

e.g.

Common Functions

=SUM > Used for all mathematical formulae

=SUM(A1+S5)

=AVERAGE > Calculates the average from a selected range of cells

=COUNT > Counts cells in a range with numeric entries

=COUNTA > Counts cells in a range with alphanumeric entries

=MIN > Shows the minimum number in a selected range of cells

=MAX > Shows the maximum number in a selected range of cells

=|F > Returns a value if a condition is satisfied
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BODMAS
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Formulae in spreadsheets are calculated in the order defined by BODMAS.

1. B

2. 0

3. D
4. M

5 A

6. S
Operands
+ >
- >
/ >
* >
>

> >
< >
>= >
<= >
= >

> Brackets

> of

> Division

> Multiplication
> Addition

> Subtraction
Addition

Subtraction

Division
Multiplication

Sum of a range

Greater than

Less than

Greater than or equals to
Less than or equals to

Equals
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Format Painter

The format painter is used when you want to paste identical backgrounds to a
selected range of cells. Select the cells that you would like to copy their format,
double click on format painter and then click in any cell that you would like to apply

that format. Click on the Esc button to deselect the format painter.

s SLY tBR-F -
Arial -0 - B T U S==H!L
A - A Faormat Pain

A, B C

=
m

1

Percentages and Absolute Cells

Absolute cells are those whose reference, wherever you drag it to stays constant, in
other words it does not change, and this is achieved by placing a $ sign in front of the

letter and number of the cell reference: e.g. $F$6

1 \ fe =SUM(B1/5B54)
A B C
1 Flights Lm234.45| 39%!
2 Hotels Lm345.21 57%
3 Insurance LmzZ3.99 4%
4 LmB03 .65

The above example shows the use of absolute references, in this case cell B4, which
are used to calculate the percentage of each of the expenses from the total (i.e. each
amount divided by the sum of the total). Hint to make a cell absolute instead of typing

in the $ signs, place the cursor before the cell reference and press F4.
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Merge Cells

. =
To merge cells use the merge icon:

Before Merge:

A1 - pis

After Merge:

B& - B

}

Cut, Copy, Paste and Paste Special

B
The Cut, Copy and Paste buttons & are located on the Standard toolbar.

Cut: Moves the contents from their current location

Copy: Makes an identical copy of the contents in multiple places

Paste: Inserts the Cut or Copied data

Paste Special: Is used when copying data in formulae from one spread/work
sheet to another.
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Headers and Footers

To insert headers and/or footers use the following procedure: View > Header and

Footer

The following window will appear:

Fage Setup

Custom Header lets

Page

Matains

you insert text. See
next screenshot

l Sheet V

Header:

Print...

|

Print Prewview I

|{nu:-ne}

Custom Header, .,

options. ..

Cuskom Fooker. ..

(R Bl

&
Format text

Insert Page Number

Date

he Font butto

Left section:

e number,

ke, time, File path, filename, ar tabl name: position the

Page X of Y

briafe butkon,
alf wour pickure

Time

Al Bjof al8|o]| =¥

Cenker section: Right section:

Fooker:
||{nu:une:|
Custom Footer lets
you insert text. See
next screenshot.
|
(4 | Cancel I
Header 4 Header/Footer E]
——

04
=N

Cancel

»
»

/

Text alignment Left / Centre / Right

Page 7 of 20



St. Michael Foundation

Page Setup

Page layout

\

ECDL Module 4 Vers. 1.1

Page Set\lp

- " Landscape

* Porkrait

Scaling —

* adiustta: 100 =2 %% normal size

™ Fit ko 11 Ej‘ pagels) wide by |1 Ei: Eall

Paper size:

JLetter _:J
|80 dpi -]

Auta

Print guality:

First page number:

Prink. .. ‘

Prink Presview ]

Qpkions. .. ]

o]

Cancel

Borders

You may insert borders by clicking on the — ™ button.

Craw Borders. ..
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Format Cells

Right clicking on any cells lets you change the format of an cell or range of cells.

1y o
Copy

@ Paste

Paste Special...

Insert...
Delete...

Clear Conkents

d  Insert Comment
I I L | I I I I I I

I Format Cells. .. I

Add Wakch
W Hyperlink...

Number
To change the numeric format of any cell (hnumeric, currency, percentage etc): Right

click on the cell > Format cells > choose desired option from the window.

Format Cells \

Numbel Alignment ] Font ] Border l Patterns ] Prokection l
Category: Sample

General

Murnber J

Currency

Accounking
[Date

Time
Percentage
Fraction
Srientific
Text

General format cells have no
specific number Farmat.

Special

Custan J Select the format of the cell
contents that you require,
you can also adjust the
decimal point location

(04 | Cancel
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Alignment

-

Format Cells

Murmber

Lets you select

ECDL Module 4 Vers. 1.1

B%)

the alignment in
your selected

Text direckion;

Protection l

cells.

Text alignment PRk ation
Horizontal; Tl
|General / - 0_

= T
Wertical: 0 = 3
Texk —#
|Ei|:|tt|:|m X ﬂ * i
t .
I_ ; ‘,
Texk conkral * -
[ ‘Wrap bext
[ sShrink ko Fit 1] 3, Degrees
[ Merge cells
Right-ta-left

Allows you to put
text on multiple lines

|Cu:untext j in one cell
ok | Cancel
Borders
Format Cells
cl | Mumber | Alignrent I Fant l Patterns ] Pratection I
ear styles
y \ Presets Line
Skyle:

Cutline

Border position
selection

diagram or the buttons above.

Color:

Border style
selection

The selected border style can be applied by clicking the presets, preview

Autarmatic ‘z'\-

Border colour
selection

o]

Cancel

Page 10 of 20



St. Michael Foundation ECDL Module 4 Vers. 1.1

Zoom

You can zoom the sheet size by clicking on the i

button, typing in the
required size and hitting Enter to select.

I o100 -
bl 4% @) .
== -0 A,

i
I
"

Figure1 BEFORE ZOOM

o153 -
I 4 .
=L oA,

F (

Figure2 AFTER ZOOM

Naming Cells

By naming a cell you can always use the name in formulae to import any value

stored in that cell, in the following example Cell Al is renamed VAT, in this way a
formula that previously referred to cell Al:

=SUM(B1*A1)
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May now be written as

=SUM(B1*VAT)

Figure 3 shows Cdll still named asAl

Figure 4 showsthe same cell now renamed as VAT

Standard Toolbar buttons

P IS

Font Type Font Size Bold Italics Underline Align text Left / Centre / Right

Printing

S T

Print Print Preview

Charts

Charts my be created in Excel by first selecting the cells that you wish to

incorporate into your chart and then by pressing the chart wizard button
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Four main /
charts required
in the ECDL " Charts wizard takes

four stages to complete

Freezing Cells

By freezing panes you can stop the frozen cells from disappearing as you scroll
down or across.

Figure 5 shows panes have been frozen to the left and above the active cell

Figure 6 showsthe scroll down with the first row frozen in place
Hiding Rows/Columns

To hide a row or a column, select it by right clicking on the Column letter or Row
number and from the drop down menu select the Hide option, to unhide the
column/row, select the rows/column before and after the hidden row/column, and

from the drop down menu select Unhide.
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RLLN
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o
*
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LT

Renaming Worksheets

To rename a worksheet, double click on its name and enter the new one

/

Inserting Worksheets / Rows / Columns

To insert a new worksheet select Insert > Worksheet from the Standard Menu
bar.

“‘|l-l...
L
\d

"
DL TN L A

To insert a new row or column select the row or column where you would like to
insert it and select Insert > Row or Column from the Standard Menu bar.

RS Rk 2

*
n [
" ’l

*
“aggus®
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Sorting

Sorting is the arranging of data in cells in ascending or descending order

Figure 7 shows column before Sort

Figure 8 shows same column after Sort

More complex sorts involving more than one column may be done by selecting
Data > Sort from the Standard Menu bar.

This Sort lets you —>
arrange the data in

the columns and sort \
in three consecutive

orders. \

Page 15 of 20



St. Michael Foundation ECDL Module 4 Vers. 1.1

Column Width

To adjust the column or row width, place the cursor between the column or row
name and adjust the width

Place cursor here, it will turn into
a beam with two arrows, drag
apart

To automatically adjust all column or row widths in a worksheet select the box
between column A and row 1, this will select ALL the cells in the worksheet and
press Format > Column > Autofit (This may also be done with rows)

Selecting this
box highlights
all cells in
worksheet

v

You may also adjust the column and/or row sizes by right clicking or the
individual or range of rows or cells and selecting row/column height from the
menu

‘-I-l-,
. N
..ll-l‘

Figure 9 shows example of row height adjustment

Drag Cells

To move contents of a cell place the cursor on the edge of the Active Cell, this
will change to a four arrow crosshair, drag to any cell you require.
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/ Place cursor here

To copy cells place the cursor on the bottom right hand corner of the Active Cell,
over the square, this will turn to a solid ‘+’ sign and drag down or across, copying
the contents

Place cursor here

and drag down to
/ copy.

Cells may also be copied to different worksheets and to different spreadsheets.

Replication

You may drag down a formula and increment the cell references by one.

Figure 10 Placethe cursor on the bottom right hand cor ner of the Active Cell

Figure 11 showsthe end result
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Showing Formulae

To show all the formulae on your worksheet select Tools > Options and from the
drop down menu, under the View tab, select Formulas

Formulas

Margins

To adjust the printout margins or to centre your spreadsheet on the printout
select File > Page Setup, ensure that you are on the Margins tab.

Margins Tab f

Centre printout \ Margins Settings

Page 18 of 20



St. Michael Foundation ECDL Module 4 Vers. 1.1

Other print options

Print with gridlines

<4— Print with rows and
headings

Automatic title

Ensuring that you are in Landscape view, select File > Page Setup > Sheet tab

Select rows to insert, these will automatically be printed out on every sheet

Moving or Copying worksheets between workbooks

You can move or copy an entire worksheet between workbooks by using the
following procedure:

Open the worksheet that you would like to move/copy, right click on sheet tab
(located at the bottom of the sheet-see following diagram)
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Click onthe
/ Move or copy
and anew
window will
open

Asks which workbook to

/ move/copy the worksheet to

Position of the sheet

The program is set to move the
worksheet by default, if you
want to leave a copy select this
check box.

\
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